FlexHub Forum

addcmd error

addcmd error
« on: July 19, 2012, 23:26:15 »
         1      Display text in PM instead of mainchat

 !addcmd regmess -o1 -p-1 -m10 -t30m "

  Download And Searches Blocked For Unregistered Users

  Register yourself Using !regme (space) Password

If you would like to register type in mainchat +regme <password>"
[23:24:42] <·ADE·> Error: You can only use the timer (-t) on messages to all (option 2 must be included) Use !addcmd -h for more details.

 ???

Offline massi

  • FlexHub Ambassador and Forum Stalker
  • *
  • 301
Re: addcmd error
« Reply #1 on: July 20, 2012, 07:28:30 »
Hello  ;)

It's not a bug (i hope ) ...

Take a look in rules to add textcommands ...

Function timer works only with option 2 ...

In your command you have choice option 1 ... it's normal that don't work ...

Take a look ...

Help for !addcmd:

    !addcmd <name> [-o<options>] [-p<profilelevel>] [-m<max profilelevel>] [-u<use profilelevel>] [-t<time>] [-h"<helptext>"] “<text>"

      <options>         A number created by adding the values of the following options:

         0      Output to mainchat (default)
         1      Display text in PM instead of mainchat         
                                       2      Show text to all (when this is used, you can use -p and -m to limit output to certain profilelevels)
         4      Show text when user logged in (welcome messages/rightclicks)
         8      Don't allow the command to be activated in mainchat (useful in combination with 4)
         16      Do not create an item in !help for this command (forced when 8 is used)
         32      Do not create a rightclick item for this command (forced when 8 is used)
         64      Text should be send in raw format instead of mainchat/pm (useful to send custom rightclicks)
         128      Only send to ADC user(s)
         256      Only send to NMDC user(s)

      <profilelevel>      (for use with option 2) A number in the range from -1 (User) to 10 (Hubowner) that is the lowest profile that will see the command output (default is -1)
      <max profilelevel>      (for use with option 2) A number in the range from -1 (User) to 10 (Hubowner) that is the highest profile that will see the command output (default is level 10)
      <use profilelevel>      A number in the range from -1 (User) to 10 (Hubowner) that is the lowest profile that can use the command (default is -1)
      <time>         (for use with option 2) Time in seconds between broadcasts, or use m for minutes, h for hours
      <helptext>      Helptext to show in !help and display in rightclick usercommands
      <text>         Text to send, must be the last parameter on the line



Take a look error ...

[23:24:42] <·ADE·> Error: You can only use the timer (-t) on messages to all (option 2 must be included) Use !addcmd -h for more details.

NB. option 2 must be included

« Last Edit: July 20, 2012, 08:42:41 by massi »

Offline massi

  • FlexHub Ambassador and Forum Stalker
  • *
  • 301
Re: addcmd error
« Reply #2 on: July 20, 2012, 07:40:39 »
Try to use this if you want ...

!addcmd regmess -o3 -p-1 -m-1 -t30m "

Download And Searches Blocked For Unregistered Users

Register yourself Using !regme (space) Password

If you would like to register type in mainchat +regme <password>"


nb... choice option 3 ... option 1+2 = 3

1 = text in PM
2 = show all ... but for level ...  -p = -1 and  -m = -1 ... only unreg ;-)

1 Display text in PM instead of mainchat
2 Show text to all (when this is used, you can use -p and -m to limit output to certain profilelevels)
« Last Edit: July 20, 2012, 08:38:29 by massi »

Offline massi

  • FlexHub Ambassador and Forum Stalker
  • *
  • 301
Re: addcmd error
« Reply #3 on: July 20, 2012, 09:08:44 »
Some administrator please move this topic in the help/support. Thanks ;-)

Offline LadyStardust

  • *****
  • 257
  • aka Puma
Re: addcmd error
« Reply #4 on: July 20, 2012, 09:53:36 »
Some administrator please move this topic in the help/support. Thanks ;-)
Yes Sir !  ;D

As Massi says: You can only use the timer (-t) on messages to all (option 2 must be included) .
Best regards,
LS

Offline massi

  • FlexHub Ambassador and Forum Stalker
  • *
  • 301
Re: addcmd error
« Reply #5 on: July 20, 2012, 09:57:53 »
Thanks Lady Stardust :)

Re: addcmd error
« Reply #6 on: July 20, 2012, 12:04:57 »
Thanks massi / Lady  ;D

Offline þ††i£øû]v[™

  • ***
  • 103
  • ::.(Ô;Ô).::
Re: addcmd error
« Reply #7 on: September 30, 2012, 10:58:58 »
yes option 2
ty Lady  :D
þ††i£øû]v[™

Re: addcmd error
« Reply #8 on: February 15, 2013, 15:09:16 »
massi no copy text of flex i looking text cmd
please write comand for me +radio
righ click user -1 to 10 ok tnks