FlexHub Forum

would it be possible to run flexhub on an ARM system?

would it be possible to run flexhub on an ARM system?
« on: September 15, 2012, 10:16:28 »
Ive been thinking a long time on running flexhub on an raspberry pi that has arm cpu and runs ubuntu arm version ive tried installing one last night on one i first installed lua on it used this.


"apt-get install lua", and it installed version 5.0. 5.2 is now available. It just takes a few more commands to install that. From your home (or desired directory):

wget http://www.lua.org/ftp/lua-5.2.0.tar.gz [download source]
tar xzvf lua-5.2.0.tar.gz [unpack]
cd lua-5.2.0 [switch to new directory]
sudo apt-get install libreadline5-dev [install a required library]
sudo make linux install [build & install lua]


yeah i know still needs to follow newbie guides when im installning something in linux.

After that i tried the normal startup for flex

 pi@raspberrypi ~/FlexHub $ chmod +x lua
pi@raspberrypi ~/FlexHub $ sudo ./lua ./FlexHub.lua --nogui
./lua: 1: ./lua: Syntax error: "(" unexpected


So now im wondering is there something that i did wrong or does flex just need some modification to get it running?


And if any flex dev want to test themself just pm me and i can get you an account on the rasp server.

Re: would it be possible to run flexhub on an ARM system?
« Reply #1 on: September 15, 2012, 17:39:59 »
cd FlexHub
sudo ./lua ./FlexHub.lua --nogui --nick= your Pseudo --pass=your password --port=your port

Offline FlipFlop™

  • FlexHub Developer
  • *****
  • 505
Re: would it be possible to run flexhub on an ARM system?
« Reply #2 on: September 16, 2012, 20:30:46 »
Installing Lua 5.2 or another Lua distribution won't help to get FlexHub running, it uses it's own Lua 5.1.4 binaries included in the FlexHub folder, and all the included libraries depend on that.

Have tried running it on a VM RaspberryPi emulation, but i'm getting the same error:

./lua: 1: ./lua: Syntax error: "(" unexpected

or:

bash: ./lua: cannot execute binary file

So I suspect it would need a specially compiled version for Unix with ARM processors, the current distribution will only work on x86 based processors.

We can't compile something like that ourselves, we simply lack the knowledge. So if anyone knows someone who could do that, please let us know!
Check the new FlexHubList!           Add awesome statistics like this for your hub!

This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

Re: would it be possible to run flexhub on an ARM system?
« Reply #3 on: April 19, 2013, 15:54:15 »
Hallo

Are flexhub working on RaspberryPi in the new versions or ?

Re: would it be possible to run flexhub on an ARM system?
« Reply #4 on: April 20, 2013, 11:44:07 »
No it does not.

Even if I would love to say when it will I am not going to promise anything at this stage.

/1d