FlexHub Forum

Swedish letters in Main Chat doesn't appear

Swedish letters in Main Chat doesn't appear
« on: October 22, 2013, 17:08:03 »
Hi.
I've recently installed Flexhub on an Windows server 2008 R2 machine in ESXi.
Everything runs fine but the swedish letters won't show in main chat.
I've tried both standard Windows-1251 and UTF-8, none works.

Any thoughts?

Offline FlipFlop™

  • FlexHub Developer
  • *****
  • 505
Re: Swedish letters in Main Chat doesn't appear
« Reply #1 on: October 22, 2013, 18:34:01 »
The default is Windows-1252.

Is there any error when you try to set the charset with !set char_set ?
Which version of FlexHub are you running?
Check the new FlexHubList!           Add awesome statistics like this for your hub!

This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

Re: Swedish letters in Main Chat doesn't appear
« Reply #2 on: October 23, 2013, 08:36:56 »
The default is Windows-1252.

Is there any error when you try to set the charset with !set char_set ?
Which version of FlexHub are you running?

Oh, well, then i've tried both 1252, 1251 and UTF-8 xD
No, it says it successfully changed char_set.
I'm running FlexHub Beta 0.2 svn: 1466

Offline FlipFlop™

  • FlexHub Developer
  • *****
  • 505
Re: Swedish letters in Main Chat doesn't appear
« Reply #3 on: October 23, 2013, 09:45:48 »
There has been a charset handling change in svn 1469.

Can you use '!update now' to update your hub to svn 1469, and see if that helps?
Charset should be set to Windows-1252 then.

A few more questions:
- Are you using ADC or NMDC?
- Can you paste an example of text that doesn't display well?

Check the new FlexHubList!           Add awesome statistics like this for your hub!

This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

Re: Swedish letters in Main Chat doesn't appear
« Reply #4 on: October 23, 2013, 11:11:50 »
There has been a charset handling change in svn 1469.

Can you use '!update now' to update your hub to svn 1469, and see if that helps?
Charset should be set to Windows-1252 then.

A few more questions:
- Are you using ADC or NMDC?
- Can you paste an example of text that doesn't display well?



Charset is windows-1252 now and i've updated to the latest software, svn 1469.
Me and my friend are both using NMDC.
If I send this message in MC:
[11:07:01] <[GUD]MrNysa> Jag är på öland i dag, du då?
It displays like this for my friend:
[11:07:01] <[GUD]MrNysa> Jag r p land i dag, du d?

It's also viceversa, whatever he types with åäö, it will just skip those letters.

Can't be clients fault since I'm connected to a bunch of other Flexhub hubs running svn 1417 for instance, and swedish letters works there

Offline FlipFlop™

  • FlexHub Developer
  • *****
  • 505
Re: Swedish letters in Main Chat doesn't appear
« Reply #5 on: October 23, 2013, 11:14:52 »
Make sure that in your Favorite Hubs properties for the hub, the charset is set to Windows-1252 too.

If that still doesn't work, please connect to dchub://support.flexhub.org:8000 and drop me a PM, so we can fix this.
Check the new FlexHubList!           Add awesome statistics like this for your hub!

This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

Offline sergius_s

  • *
  • 236
  • Be yourself...
Re: Swedish letters in Main Chat doesn't appear
« Reply #6 on: October 23, 2013, 12:39:24 »
I'm not sure that it will help, but nevertheless:

for central Europe - windows-1250
for western Europe - windows-1252

Windows-1251 contains Cyrillic, your characters look like Russian letters, but not sure what will suit you...

Also you can try to write something on one of the Russian or Ukrainian hubs (they have charset windows-1251)
- I'm sorry for my terrible english...

Offline FlipFlop™

  • FlexHub Developer
  • *****
  • 505
Re: Swedish letters in Main Chat doesn't appear
« Reply #7 on: October 23, 2013, 12:50:50 »
Swedish characters should work fine with Windows-1252 in NMDC, I've tested with svn 1469.

You can check in dchub://support.flexhub.org:8000
Check the new FlexHubList!           Add awesome statistics like this for your hub!

This post is a natural product. The slight variations in spelling and grammar enhance its individual character and beauty and in no way are to be considered flaws or defects.

Re: Swedish letters in Main Chat doesn't appear
« Reply #8 on: October 23, 2013, 14:50:31 »
Swedish characters should work fine with Windows-1252 in NMDC, I've tested with svn 1469.

You can check in dchub://support.flexhub.org:8000


Seems to be working now after the software update.
Strange thing is, one of my fav hubs is running  svn 1417 with swedish letters.
Any way, thanks for the fast & good support :)

Re: Swedish letters in Main Chat doesn't appear
« Reply #9 on: November 09, 2013, 18:12:12 »
There is one issue that is quite common with FlexHub that does not appear with other hubsofts (for obvious reasons). If you change the protocol in hub favs in the client, the client will change the charset will update in one direction (from nmdc to adc) but NOT the other way.

For example if you add a nmdc hub (dchub://support.flexhub.org:8000) the charset will be set to win 1252 (for us in western europe at last), if you change the addy to adc://support.flexhub.org:8000 the client will change the setting to utf8.

This feature is good as it prevents errors.

BUT if you do the opposite the client will NOT edit your charset in hub favs and having it set to utf when connecting to FlexHub using nmdc protocol will lead to weird behaviour as characters are stripped from messages

/1d