FlexHub Forum

FlexHub General => Report a bug => Topic started by: Hamachi on August 31, 2011, 15:40:44

Title: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: Hamachi on August 31, 2011, 15:40:44
if i connect whit one client after some sec join whit a other one, but cant join join becomes of Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Title: Re: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: FlipFlop™ on August 31, 2011, 15:44:29
That's not a bug, that's a security feature. It prevents problems when someone is connection hammering.
Title: Re: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: Hamachi on August 31, 2011, 18:54:17
okay...

but i dont understand why it shall do it if users is reg.

No problem ;)
Title: Re: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: LadyStardust on September 17, 2011, 16:40:18
In big hubs there is thousands of regs, so reason is same as for users.

You can change it if you like, make reg profile to override security setting by:
!override <profilename> <setting> [false]
Title: Re: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: FlipFlop™ on September 18, 2011, 15:31:56
No you can't override it based on a profile.

The 'too fast reconnect-check' is done before the login procedure starts, so there's no nickname or profile known to the hub yet. But if you have a reg-only hub, you can remove the reconnect-delay by using:

!set reconnect_timeout 0
Title: Re: Reconnecting too fast, you have to wait 20 seconds before reconnecting.
Post by: FlipFlop™ on September 18, 2011, 16:26:42
To only override the reconnect timeout for a certain IP, you can use !protect <ip>
Ofcourse then kicking or banning such an IP won't work, and some other checks are skipped as well.