FlexHub Forum

FlexHub General => Feature requests => Topic started by: Logicwax on January 15, 2014, 21:12:24

Title: Linux x64 support
Post by: Logicwax on January 15, 2014, 21:12:24
Is Linux x64 support planned?     What exactly needs to be done to support 64-bit Linux?

If it's the Lua binaries, why exactly is Flexhub using it's own Lua binaries (i read that it does, in the ARM/raspberry pi discussion thread).




Title: Re: Linux x64 support
Post by: FlipFlopâ„¢ on January 16, 2014, 00:07:58
Linux x64 is planned, but it's a longterm planning. You could install some 32 bit libs to run Flex in 32bit mode on x64 though: http://www.flexhub.org/forum/index.php/topic,713.msg2286.html#msg2286

Currently Flex uses the binaries from LuaAIO (unmodified): http://files.luaforge.net/releases/luaaio/luaaio
We want to move to LuaJIT at some point, and drop LuaAIO since it's unmaintained. But that takes some major rewriting because LuaAIO has an OS thread ability that is used now. We'll have to change that to a coroutines/Copas solution instead.

The source for most of the libraries included with LuaAIO can be downloaded here: http://flexhub.org/downloads/source/flexhub-libs-source.zip

The only lib for which source is missing is the 'dc' lib, that handles key/lock for NMDC and hashing and Base32 for passwords for ADC. It's probably possible to ditch this one in favor of a pure lua solution though.