FlexHub Forum

FlexHub General => Announcements => Topic started by: en_dator on April 29, 2012, 21:40:54

Title: Flexhub Beta 0.2 svn 1308 released
Post by: en_dator on April 29, 2012, 21:40:54
Hopefully the last of the updates fixing issues in 1303  ;D

For this update a restart of the hub is not needed if updating from 1304.

Use '!update now' in your hub or download it from the download section linked above.

Changelog for this release:
Code: [Select]
svn 1308
- fixed : errorhandling when tCurrent or a subtable doesn't exist yet
- fixed : display of protocol in description for ADC
- fixed : showlog fixed
* changed : feed level of save settings set to level 2
* changed : reverted the CID check changes, made it all wrong and caused more ghosting :D


NOTE: For !restart to work when running multiple FlexHubs, you'll have to make sure that the files you start the hub with, have a unique name. For Windows this means renaming both FlexHub.lua and FlexHub.exe (both the .exe and the .lua need to have the same name though), for Linux this means renaming FlexHub.lua only. So for example in Windows: rename FlexHub.lua to FlexHub1.lua and FlexHub.exe to FlexHub1.exe.

NOTE: Linux --nogui version needs the file: bit.so in the FlexHub lib-folder, available in the Linux archive in download section if you don't already have it. The FlexHub team currently does not support or supply Linux x64 versions.

NOTE: After '!update now' the hub will tell you if it needs a !restart or if you can just use !rs (reload scripts) instead. If the path to FlexHub.exe contains spaces the hub will have to be started once manually if it was running svn 1108 or earlier before updating, a correct restart script (for use with !restart) will only be created on manual startup.

Keep giving feedback!

Regards, the FlexHub team